Back
Resolved

RealmJoin AppStore unavailable

Started 11 Feb at 11:15am CET.

portal.realmjoin.com
Created

We are currently investigating an issue regarding the AppStore and display of packages.

Update: We found the issue and resolved the incident.

Posted 11 Feb at 11:15am CET.